正在加载
请稍等

菜单

Home 码农菜园 虚机配置 Python常见问题:Python的升级
Home 码农菜园 虚机配置 Python常见问题:Python的升级

Python常见问题:Python的升级

虚机配置 by   阅读量 5,199

在centos上,有时候系统自带的python是2.6.6,导致很多要求python2.7以上的包不能使用,以下介绍在centos上将python从2.6升级到2.7的方法。

首先查看python版本。

然后下载python2.7.3。

解压文件。

进入文件夹后安装。

查看版本信息,用的是python2.7。

建立软链接,使系统默认的python指向python2.7。

再使用python查看版本信息,已经是2.7了。

python升级后,由于系统的yum不兼容python2.7,导致yum不能正常工作,因此需要指定yum的python版本。

将文件头部的python改为python2.6.6,即:

至此,完成centos上python的升级。

26 2016-06

发表评论